aboutsummaryrefslogtreecommitdiff
path: root/c_implementation/Makefile.am
diff options
context:
space:
mode:
authorkaotisk <kaotisk@arching-kaos.org>2025-04-02 20:54:37 +0300
committerkaotisk <kaotisk@arching-kaos.org>2025-04-02 20:54:37 +0300
commitb9f80a2b37edf9682f189b406542b3f7a93b24a3 (patch)
tree2c96484ccb77af8a59ed6fb7fe4632b5bafb9858 /c_implementation/Makefile.am
parent0ec3188626275fa2678882c9827ade8d045ffc7d (diff)
downloadarching-kaos-tools-b9f80a2b37edf9682f189b406542b3f7a93b24a3.tar.gz
arching-kaos-tools-b9f80a2b37edf9682f189b406542b3f7a93b24a3.tar.bz2
arching-kaos-tools-b9f80a2b37edf9682f189b406542b3f7a93b24a3.zip
Moved directory and some experimental changes
Diffstat (limited to 'c_implementation/Makefile.am')
-rw-r--r--c_implementation/Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/c_implementation/Makefile.am b/c_implementation/Makefile.am
new file mode 100644
index 0000000..507550f
--- /dev/null
+++ b/c_implementation/Makefile.am
@@ -0,0 +1,27 @@
+ACLOCAL_AMFLAGS = -I m4
+AM_CPPFLAGS = -I$(top_srcdir)/include
+
+
+# Link each test to the library
+#$(test_programs): % : %.c
+# $(CC) $(AM_CPPFLAGS) $(CPPFLAGS) $(CFLAGS) -o $@ $< $(LDFLAGS) libmylib.la
+#
+#
+# Build shared library from root dir sources
+
+lib_LTLIBRARIES = libaklog.la
+libaklog_la_SOURCES = $(top_srcdir)/src/aklog.c
+include_HEADERS = include/libaklog.h
+
+## Build tests (no SUBDIRS needed)
+check_PROGRAMS = test_aklog
+test_aklog_SOURCES = ./tests/test_aklog.c
+test_aklog_LDADD = libaklog.la
+tests_test_main_CPPFLAGS = -I$(top_srcdir)/include # For tests too
+
+# Enable 'make check' to run tests
+TESTS = $(check_PROGRAMS)
+
+# Optional: Clean test binaries aggressively
+CLEANFILES = $(TESTS)
+