aboutsummaryrefslogtreecommitdiff
path: root/c_implementation/Makefile.am
diff options
context:
space:
mode:
authorkaotisk <kaotisk@arching-kaos.org>2025-04-03 21:19:12 +0300
committerkaotisk <kaotisk@arching-kaos.org>2025-04-03 21:19:12 +0300
commit7916ece51b3321823cbfde78ecf16dcd9222226d (patch)
tree9a1ad6085070b6d0e54ded586f57b2e0f29f8166 /c_implementation/Makefile.am
parent132440104780425bfb5df2eb1a535cb93aa7dbec (diff)
downloadarching-kaos-tools-master.tar.gz
arching-kaos-tools-master.tar.bz2
arching-kaos-tools-master.zip
[cleanup] comments removalHEADorigin/masterorigin/HEADmaster
Diffstat (limited to 'c_implementation/Makefile.am')
-rw-r--r--c_implementation/Makefile.am23
1 files changed, 9 insertions, 14 deletions
diff --git a/c_implementation/Makefile.am b/c_implementation/Makefile.am
index 507550f..87089cb 100644
--- a/c_implementation/Makefile.am
+++ b/c_implementation/Makefile.am
@@ -1,27 +1,22 @@
ACLOCAL_AMFLAGS = -I m4
AM_CPPFLAGS = -I$(top_srcdir)/include
-
-# Link each test to the library
-#$(test_programs): % : %.c
-# $(CC) $(AM_CPPFLAGS) $(CPPFLAGS) $(CFLAGS) -o $@ $< $(LDFLAGS) libmylib.la
-#
-#
-# Build shared library from root dir sources
-
-lib_LTLIBRARIES = libaklog.la
+lib_LTLIBRARIES = libaklog.la libaksettings.la
libaklog_la_SOURCES = $(top_srcdir)/src/aklog.c
-include_HEADERS = include/libaklog.h
+libaksettings_la_SOURCES = $(top_srcdir)/src/aksettings.c
+include_HEADERS = include/libaklog.h include/libaksettings.h
+
+bin_PROGRAMS = ak
+ak_LDADD = libaklog.la
+ak_SOURCES = src/ak.c
-## Build tests (no SUBDIRS needed)
check_PROGRAMS = test_aklog
test_aklog_SOURCES = ./tests/test_aklog.c
test_aklog_LDADD = libaklog.la
-tests_test_main_CPPFLAGS = -I$(top_srcdir)/include # For tests too
-# Enable 'make check' to run tests
+tests_test_main_CPPFLAGS = -I$(top_srcdir)/include
+
TESTS = $(check_PROGRAMS)
-# Optional: Clean test binaries aggressively
CLEANFILES = $(TESTS)